唯一股票网

当前位置:首页 > 配资公司 >

炒股配资开户:七指金叉共振点指标源码 七金叉共

2020-05-26 16:14:11 配资公司

炒股配资开户:七指金叉共振点指标源码七金叉共振选股公式这个就是七指共振指标源码放入附图后的效果图,最后面的源码只需要复制下来粘贴到自己的系统中去就可以了。

原理其实很简单,就是七个指标同时发生金叉共振,会发出信号,这七个指标,我在这里是用了:量能、CCI、MACD、SAR、RSI、KDJ、CJDX,当然,懂得这个原理后,你可以编辑八指共振、十指共振等等,就是几个指标同时发出买入信号,目的是进一步确认趋势。

图上的洋红色表示指标金叉以后,绿色表示死叉以后,当七个指标同时都处在多头趋势时就会发出七指共振信号。

严格来说,七指共振应该是七个指标同时金叉才对,但是这种情况少之又少,同时处在上升通道还是比较常见,所以,我们在看盘的时候,不要认为图上的洋红色是金叉了,由绿色变洋红色才是金叉,也就是,第一次出现洋红色才是金叉出现,以后的洋红色就是指标持续向上发散。

大家可以试着用其他七个指标做出七指共振,并且,任何指标公式都可以变成选股公式,七指共振当然也不例外,我们可以通过参数的设置来选股,可以设置选股条件为几个指标由绿变红,也可以设置当天有多少个指标是洋红色,等等。

七指共振技术指标源码:STICKLINE(MA(V,5)>MA(V,10),)COLORLIMAGENTA;STICKLINE(MA(V,5)DRAWTEXT(ISLASTBAR=1,1,"筹码"),COLORFFFFFF;TYP:=(HIGH+LOW+CLOSE)/3;CCI:=(TYP-MA(TYP,14))/(*AVEDEV(TYP,14));STICKLINE(CCI>0,)COLORLIMAGENTA;STICKLINE(CCI<0,)COLORGREEN;DRAWTEXT(ISLASTBAR=1,2,"CCI"),COLORFFFFFF;DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIFF,9);STICKLINE(DIFF>DEA,)COLORLIMAGENTA;STICKLINE(DIFFDRAWTEXT(ISLASTBAR=1,3,"MACD"),COLORFFFFFF;CC:=(C+O+H+L)/4;STICKLINE(CC>SAR(4,2,20),)COLORLIMAGENTA;STICKLINE(CCDRAWTEXT(ISLASTBAR=1,4,"SAR"),COLORFFFFFF;LC:=REF(CLOSE,1);RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;RSI2:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;STICKLINE(RSI1>RSI2,)COLORLIMAGENTA;STICKLINE(RSI1DRAWTEXT(ISLASTBAR=1,5,"RSI"),COLORFFFFFF;RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);STICKLINE(K>D,)COLORLIMAGENTA;STICKLINE(KDRAWTEXT(ISLASTBAR=1,6,"KDJ"),COLORFFFFFF;VAR1:=(2*CLOSE+HIGH+LOW)/4;VAR2:=EMA(EMA(EMA(VAR1,4),4),4);J:=(VAR2-REF(VAR2,1))/REF(VAR2,1)*100;DD:=MA(J,3);KK:=MA(J,1);STICKLINE(KK>DD,)COLORLIMAGENTA;STICKLINE(KKDRAWTEXT(ISLASTBAR=1,7,"CJDX"),COLORFFFFFF;T:=MA(V,5)>MA(V,10)ANDCCI>0ANDDIFF>DEAANDCC>SAR(4,2,20)ANDRSI1>RSI2ANDK>DANDKK>DD;七指共振:IF(TANDREF(T,1)=0,)STICK,COLORRED,LINETHICK6;DRAWTEXT(TANDREF(T,1)=0,0.3,"七指共振")COLORRED;DRAWICON(TANDREF(T,1)=0,0,1);N1:=IF(CROSS(MA(V,5),MA(V,10)),1,0);N2:=IF(CROSS(CCI,0),1,0);N3:=IF(CROSS(DIFF,DEA),1,0);N4:=IF(CROSS(CC,SAR(4,2,20)),1,0);N5:=IF(CROSS(RSI1,RSI2),1,0);N6:=IF(CROSS(K,D),1,0);N7:=IF(CROSS(KK,DD),1,0);共振个数:N1+N2+N3+N4+N5+N6+N7,NODRAW;NN1:=IF(MA(V,5)>MA(V,10),1,0);NN2:=IF(CCI>0,1,0);NN3:=IF(DIFF>DEA,1,0);NN4:=IF(CC>SAR(4,2,20),1,0);NN5:=IF(RSI1>RSI2,1,0);NN6:=IF(K>D,1,0);NN7:=IF(KK>DD,1,0);

评论